What’s Vulnerable › Vulnerabilities
CVE-2026-6128: All-in-One WP Migration Unlimited Extension <= 2.84 - Authenticated (Subscriber+) Stored Cross-Site Scripting via 'ai1wm_backups_path' Parameter
- Severity: medium (CVSS 6.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-28 · updated 2026-08-28
- Weakness: CWE-79
Description
The All-in-One WP Migration Unlimited Extension plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'ai1wm_backups_path' parameter in all versions up to, and including, 2.84. This is due to insufficient input sanitization and output escaping on user-supplied attributes combined with missing authorization checks on the settings() function. This makes it possible for authenticated attackers, with Subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever an administrator accesses the plugin settings page. The vulnerability was partially patched in version 2.84.
Affected products
- servmask All-in-One WP Migration Unlimited Extension: through 2.84
References
- https://help.servmask.com/knowledgebase/unlimited-extension-changelog/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d2c4a000-94e9-42f1-bdb3-633741fcd54e?source=cve
Get alerted when CVE-2026-6128 or the next vulnerability affects your stack