What’s Vulnerable › Vulnerabilities
CVE-2026-61372: Apache Jena Fuseki: Web requests using SPARQL Update can escape file restrictions
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-03 · updated 2026-10-23
- Weakness: CWE-22
Description
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Apache Jena Fuseki. This issue affects Apache Jena Fuseki: through 6.1.0. Users are recommended to upgrade to version 6.2.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache Jena Fuseki: before 6.2.0 — fixed in 6.2.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Jena Fuseki 6.2.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/h206tpxtbzts7m254og6ffqljjdjkm84
- http://www.openwall.com/lists/oss-security/2026/08/03/5
Get alerted when CVE-2026-61372 or the next vulnerability affects your stack