What’s Vulnerable › Vulnerabilities
CVE-2026-61374: Apache Thrift: Java TSaslTransport post-auth data-frame missing size limit
- Severity: high (CVSS 7.1 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-02 · updated 2026-10-03
- Weakness: CWE-770
Description
Allocation of Resources Without Limits or Throttling vulnerability in Apache Thrift Java bindings. This issue affects Apache Thrift: before 0.25.0. Users are recommended to upgrade to version 0.25.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache Thrift: before 0.25.0 — fixed in 0.25.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Thrift 0.25.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/33otcgbqd27wf6qq810q56znzbomnhg1
- https://lists.apache.org/thread/35831rngzrqky1gvc32t06psgq1b8441
Get alerted when CVE-2026-61374 or the next vulnerability affects your stack