What’s Vulnerable › Vulnerabilities

CVE-2026-61398: Apache CloudStack: Cross-Site Scripting (XSS) Vulnerability in Instance Reset Password Function in UI

Description

Improper Encoding or Escaping of Output vulnerability in Apache CloudStack's UI while using Instance Reset Password functionality. This issue affects Apache CloudStack: from 4.15.1.0 through 4.20.3.0 and from 4.21.0.0 through 4.22.1.0. Users are recommended to upgrade to version 4.20.3.1 or 4.22.1.1 or later, which fixes the issue.

Affected products

How to fix

Upgrade to a fixed version: Apache Software Foundation Apache CloudStack 4.20.3.1, 4.22.1.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-61398 or the next vulnerability affects your stack