What’s Vulnerable › Vulnerabilities
CVE-2026-61400: Apache CloudStack: Get and Run Diagnostics Command Injection
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-21 · updated 2026-10-16
- Weakness: CWE-77
Description
Improper Neutralization of Special Elements used in a Command ('Command Injection') vulnerability in Apache CloudStack's run and get diagnostics functionality for the system VMs and virtual routers. An authenticated user holding the permissions required to invoke either `getDiagnosticsData` or `runDiagnostics` can achieve arbitrary command execution on the system VM and/or Virtual Router instances, with commands running as root (or as the diagnostics-process user, at minimum). This represents a full compromise of the affected instance and, depending on network segmentation, may provide a foothold for lateral movement within the CloudStack-managed infrastructure, including access to guest network traffic handled by the compromised Virtual Router. The getDiagnosticsData and runDiagnostics APIs are restricted to only Admin role accounts by default. This issue affects Apache CloudStack: from 4.20.0.0 through 4.20.3.0 and from 4.21.0.0 through 4.22.1.0. Users are recommended to upgrade to version 4.20.3.1 or 4.22.1.1 or later, which fixes the issue.
Affected products
- Apache Software Foundation Apache CloudStack: from 4.20.0.0 before 4.20.3.1; from 4.21.0.0 before 4.22.1.1 — fixed in 4.20.3.1, 4.22.1.1
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache CloudStack 4.20.3.1, 4.22.1.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-61400 or the next vulnerability affects your stack