What’s Vulnerable › Vulnerabilities
CVE-2026-61426: PraisonAI before 1.7.3 Unauthenticated Agent Access via Insecure Defaults
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-11 · updated 2026-10-25
- Weakness: CWE-200
Description
PraisonAI before 1.7.3 contains an insecure default configuration that binds to all interfaces with no API key requirement and wildcard CORS. Unauthenticated attackers can call GET /api/agents to read agent instructions and system prompts, or POST /api/chat to invoke agents without authentication.
Affected products
- MervinPraison PraisonAI: before 1.7.3 — fixed in 1.7.3
How to fix
Upgrade to a fixed version: MervinPraison PraisonAI 1.7.3. Check the vendor advisory for mitigations.
References
- https://github.com/MervinPraison/PraisonAI/security/advisories/GHSA-6wjp-v33h-5cvq
- https://www.vulncheck.com/advisories/praisonai-before-unauthenticated-agent-access-via-insecure-defaults
- https://github.com/MervinPraison/PraisonAI/security/advisories/GHSA-6wjp-v33h-5cvq
Get alerted when CVE-2026-61426 or the next vulnerability affects your stack