What’s Vulnerable › Vulnerabilities
CVE-2026-61431: PraisonAI before 4.6.78 Path Traversal via ContextGatherer
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-10 · updated 2026-10-24
- Weakness: CWE-22
Description
PraisonAI before 4.6.78 contains a path traversal vulnerability in ContextGatherer that fails to validate include paths in .praisoncontext and .praisoninclude files. Attackers can supply absolute paths or parent directory traversal sequences to read arbitrary files outside the workspace and include their contents in the generated context bundle.
Affected products
- MervinPraison PraisonAI: before 4.6.78 — fixed in 4.6.78
How to fix
Upgrade to a fixed version: MervinPraison PraisonAI 4.6.78. Check the vendor advisory for mitigations.
References
- https://github.com/MervinPraison/PraisonAI/commit/1620b49f36945d8cc8ee5635b906c960df5097a0
- https://github.com/MervinPraison/PraisonAI/security/advisories/GHSA-q7m5-3jmv-vm48
- https://www.vulncheck.com/advisories/praisonai-before-path-traversal-via-contextgatherer
- https://github.com/MervinPraison/PraisonAI/security/advisories/GHSA-q7m5-3jmv-vm48
Get alerted when CVE-2026-61431 or the next vulnerability affects your stack