What’s Vulnerable › Vulnerabilities
CVE-2026-61434: PraisonAI before 4.6.78 Allowlist Bypass via find -exec
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-10 · updated 2026-10-24
- Weakness: CWE-78
Description
PraisonAI versions before 4.6.78 contain an allowlist bypass vulnerability in shell command execution that allows attackers to execute restricted commands via find's built-in -exec, -execdir, and -delete actions. Attackers can craft find commands with these built-in actions to read blocked files, delete files, or execute non-allowlisted binaries without triggering shell metacharacter filters.
Affected products
- MervinPraison PraisonAI: before 4.6.78 — fixed in 4.6.78
How to fix
Upgrade to a fixed version: MervinPraison PraisonAI 4.6.78. Check the vendor advisory for mitigations.
References
- https://github.com/MervinPraison/PraisonAI/security/advisories/GHSA-cv3g-hj65-pcfh
- https://www.vulncheck.com/advisories/praisonai-before-allowlist-bypass-via-find-exec
- https://github.com/MervinPraison/PraisonAI/security/advisories/GHSA-cv3g-hj65-pcfh
Get alerted when CVE-2026-61434 or the next vulnerability affects your stack