What’s Vulnerable › Vulnerabilities
CVE-2026-61437: PraisonAI before 1.6.78 Remote Code Execution via tools.py
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-10 · updated 2026-10-25
- Weakness: CWE-693
Description
PraisonAI (pip package praisonaiagents) before 1.6.78 contains an unsafe dynamic module loading vulnerability in AgentFlow._resolve_pydantic_class (src/praisonai-agents/praisonaiagents/workflows/workflows.py). When a workflow step uses a string output_pydantic reference, the framework locates and imports a sibling tools.py from the workflow file's directory via importlib exec_module without sandboxing, ignoring the PRAISONAI_ALLOW_*_TOOLS environment variables. An attacker who controls a workflow file and its sibling tools.py can execute arbitrary Python code with the workflow runner's privileges when the workflow is executed via WorkflowManager or after load_yaml.
Affected products
- MervinPraison PraisonAI: before 1.6.78 — fixed in 1.6.78
How to fix
Upgrade to a fixed version: MervinPraison PraisonAI 1.6.78. Check the vendor advisory for mitigations.
References
- https://github.com/MervinPraison/PraisonAI/security/advisories/GHSA-4gfv-wg42-7jw5
- https://www.vulncheck.com/advisories/praisonai-before-remote-code-execution-via-tools-py
- https://github.com/MervinPraison/PraisonAI/security/advisories/GHSA-4gfv-wg42-7jw5
Get alerted when CVE-2026-61437 or the next vulnerability affects your stack