What’s Vulnerable › Vulnerabilities
CVE-2026-61438: PraisonAI before 4.6.78 Remote Code Execution via Broken AST Sandbox
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-15 · updated 2026-10-24
- Weakness: CWE-78
Description
PraisonAI before 4.6.78 contains a remote code execution vulnerability in JobWorkflowExecutor._exec_inline_python() due to insufficient AST validation of workflow script steps. Attackers can create malicious YAML workflow files with import os statements followed by os.system() calls that bypass sandbox checks and execute arbitrary OS commands with process privileges.
Affected products
- MervinPraison PraisonAI: before 4.6.78 — fixed in 4.6.78
How to fix
Upgrade to a fixed version: MervinPraison PraisonAI 4.6.78. Check the vendor advisory for mitigations.
References
- https://github.com/MervinPraison/PraisonAI/security/advisories/GHSA-26mh-57q7-jfvr
- https://www.vulncheck.com/advisories/praisonai-before-remote-code-execution-via-broken-ast-sandbox
- https://github.com/MervinPraison/PraisonAI/security/advisories/GHSA-26mh-57q7-jfvr
Get alerted when CVE-2026-61438 or the next vulnerability affects your stack