What’s Vulnerable › Vulnerabilities
CVE-2026-61439: PraisonAI before 4.6.78 Prompt Injection Defense Bypass
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-11 · updated 2026-10-25
- Weakness: CWE-1188
Description
PraisonAI versions before 4.6.78 contain a prompt injection defense misconfiguration where the block threshold defaults to CRITICAL severity, allowing HIGH-level threats to pass through unblocked. Attackers can submit single-vector prompt injection attacks such as instruction overrides or financial manipulation that trigger HIGH severity detection but are logged without blocking, enabling system prompt extraction and unauthorized tool invocations.
Affected products
- MervinPraison PraisonAI: before 4.6.78 — fixed in 4.6.78
How to fix
Upgrade to a fixed version: MervinPraison PraisonAI 4.6.78. Check the vendor advisory for mitigations.
References
- https://github.com/MervinPraison/PraisonAI/security/advisories/GHSA-fj8f-m44g-c479
- https://www.vulncheck.com/advisories/praisonai-before-prompt-injection-defense-bypass
- https://github.com/MervinPraison/PraisonAI/security/advisories/GHSA-fj8f-m44g-c479
Get alerted when CVE-2026-61439 or the next vulnerability affects your stack