What’s Vulnerable › Vulnerabilities
CVE-2026-61443: PraisonAI before 1.6.78 Remote Code Execution via SkillTools
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-15 · updated 2026-10-24
- Weakness: CWE-22
Description
PraisonAI before 1.6.78 contains a remote code execution vulnerability in SkillTools.run_skill_script() that executes scripts without path containment validation. Attackers can supply absolute file paths to execute arbitrary scripts from any filesystem location, including those outside the intended working directory.
Affected products
- MervinPraison PraisonAI: before 1.6.78 — fixed in 1.6.78
How to fix
Upgrade to a fixed version: MervinPraison PraisonAI 1.6.78. Check the vendor advisory for mitigations.
References
- https://github.com/MervinPraison/PraisonAI/security/advisories/GHSA-c44f-37qr-gw3f
- https://www.vulncheck.com/advisories/praisonai-before-remote-code-execution-via-skilltools
- https://github.com/MervinPraison/PraisonAI/security/advisories/GHSA-c44f-37qr-gw3f
Get alerted when CVE-2026-61443 or the next vulnerability affects your stack