What’s Vulnerable › Vulnerabilities
CVE-2026-61444: PraisonAI before 4.6.78 Code Injection via f-string
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-10 · updated 2026-10-25
- Weakness: CWE-94
Description
PraisonAI versions before 4.6.78 contain a code injection vulnerability in deploy/api.py where the agents_file parameter is directly interpolated into an f-string without sanitization. Attackers can inject arbitrary Python code that executes when the generated server code runs via subprocess.Popen().
Affected products
- MervinPraison PraisonAI: before 4.6.78 — fixed in 4.6.78
How to fix
Upgrade to a fixed version: MervinPraison PraisonAI 4.6.78. Check the vendor advisory for mitigations.
References
- https://github.com/MervinPraison/PraisonAI/security/advisories/GHSA-g6j7-pffp-8whg
- https://www.vulncheck.com/advisories/praisonai-before-code-injection-via-f-string
- https://github.com/MervinPraison/PraisonAI/security/advisories/GHSA-g6j7-pffp-8whg
Get alerted when CVE-2026-61444 or the next vulnerability affects your stack