What’s Vulnerable › Vulnerabilities
CVE-2026-61447: PraisonAI before 1.6.78 Remote Code Execution via CodeAgent
- Severity: critical (CVSS 10.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 15.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-07-11 · updated 2026-10-25
- Weakness: CWE-94
Description
PraisonAI before 1.6.78 contains a remote code execution vulnerability in CodeAgent._execute_python() that executes LLM-generated Python code without AST validation, import restrictions, or sandbox enforcement. Attackers can influence LLM output through prompt injection to exfiltrate all environment secrets and execute arbitrary code on the host system.
Affected products
- MervinPraison PraisonAI: before 1.6.78 — fixed in 1.6.78
How to fix
Upgrade to a fixed version: MervinPraison PraisonAI 1.6.78. Check the vendor advisory for mitigations.
References
- https://github.com/MervinPraison/PraisonAI/security/advisories/GHSA-2xv2-w8cq-5gxw
- https://www.vulncheck.com/advisories/praisonai-before-remote-code-execution-via-codeagent
- https://github.com/MervinPraison/PraisonAI/security/advisories/GHSA-2xv2-w8cq-5gxw
Get alerted when CVE-2026-61447 or the next vulnerability affects your stack