What’s Vulnerable › Vulnerabilities
CVE-2026-61448: Parse Server 9.0.0 Stored XSS via malformed Content-Type
- Severity: low (CVSS 2.1 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-11 · updated 2026-10-24
- Weakness: CWE-434
Description
Parse Server is affected by a stored cross-site scripting (XSS) vulnerability in versions >= 9.0.0, < 9.10.0-alpha.2 and <= 8.6.83. When an uploaded file's extension is not recognized by the mime package, Parse Server preserves the client-supplied Content-Type. A malformed Content-Type that is not a valid type/subtype media type (e.g., 'image', 'image/', or 'image//svg+xml') bypasses the fileUpload.fileExtensions blocklist and is stored unchanged. On storage adapters that persist and serve the uploaded Content-Type (such as Amazon S3, Google Cloud Storage, or Azure Blob Storage), a browser cannot parse the malformed value and falls back to MIME-sniffing; a file whose body begins with HTML is rendered as HTML, executing embedded script in the application's origin against other users who open the file URL. The default GridFS storage adapter is not affected. Fixed in 9.10.0-alpha.2 and 8.6.84.
Affected products
- parse-community parse-server: from 9.0.0 before 9.10.0-alpha.2; before 8.6.84 — fixed in 8.6.84, 9.10.0-alpha.2
How to fix
Upgrade to a fixed version: parse-community parse-server 8.6.84, 9.10.0-alpha.2. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/security/advisories/GHSA-r899-h629-j84r
- https://www.vulncheck.com/advisories/parse-server-stored-xss-via-malformed-content-type
Get alerted when CVE-2026-61448 or the next vulnerability affects your stack