What’s Vulnerable › Vulnerabilities
CVE-2026-61454: Grav before 2.0.4 Information Disclosure via __GRAV_CONFIG__
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-11 · updated 2026-10-25
- Weakness: CWE-200
Description
The Grav Admin2 plugin (getgrav/grav-plugin-admin2) before 2.0.4 embeds a global JavaScript variable window.__GRAV_CONFIG__ in the Admin2 SPA bootstrap page at /grav/admin (and its subroutes). This object is returned in every unauthenticated response and discloses the server URL, API prefix, admin base path, runtime environment type, and exact Grav and Admin2 version numbers, allowing an unauthenticated attacker to fingerprint the deployment and select version-specific exploits without reconnaissance.
Affected products
- getgrav grav: before 2.0.4 — fixed in 2.0.4
How to fix
Upgrade to a fixed version: getgrav grav 2.0.4. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/security/advisories/GHSA-pfjq-chp8-3vgh
- https://www.vulncheck.com/advisories/grav-before-information-disclosure-via-grav-config
- https://github.com/getgrav/grav/security/advisories/GHSA-pfjq-chp8-3vgh
Get alerted when CVE-2026-61454 or the next vulnerability affects your stack