What’s Vulnerable › Vulnerabilities
CVE-2026-61455: Grav before 2.0.1 Decompression Bomb via ZipArchiver
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-10 · updated 2026-10-25
- Weakness: CWE-409
Description
Grav before 2.0.1 contains a decompression bomb vulnerability in ZipArchiver::extract() that lacks limits on uncompressed size, file count, and nesting depth. Attackers can supply a crafted ZIP archive that expands to fill available disk space, causing denial of service by exhausting storage resources.
Affected products
- getgrav grav: before 2.0.1 — fixed in 2.0.1
How to fix
Upgrade to a fixed version: getgrav grav 2.0.1. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/security/advisories/GHSA-928x-9mpw-8h56
- https://www.vulncheck.com/advisories/grav-before-decompression-bomb-via-ziparchiver
- https://github.com/getgrav/grav/security/advisories/GHSA-928x-9mpw-8h56
Get alerted when CVE-2026-61455 or the next vulnerability affects your stack