What’s Vulnerable › Vulnerabilities
CVE-2026-61464: ImageMagick before 7.1.2-26 Heap Buffer Over-Write via X11
- Severity: low (CVSS 1.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-15 · updated 2026-10-29
- Weakness: CWE-122
Description
ImageMagick before 7.1.2-26 and 6.9.13-51 contains a heap-based buffer over-write vulnerability that occurs when running an X11 import with a crafted window title, which can result in heap memory corruption and denial of service.
Affected products
- ImageMagick: from 7.0.0 before 7.1.2-26 — fixed in 7.1.2-26
How to fix
Upgrade to a fixed version: ImageMagick 7.1.2-26. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-76q6-2p6h-xjqr
- https://www.vulncheck.com/advisories/imagemagick-before-26-heap-buffer-over-write-via-x11
Get alerted when CVE-2026-61464 or the next vulnerability affects your stack