What’s Vulnerable › Vulnerabilities
CVE-2026-61643: FastGPT: workflow runtime can execute another user's private HTTP toolset
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-15 · updated 2026-10-24
- Weakness: CWE-863
Description
FastGPT is a knowledge-based AI application platform. From 4.14.17 until 4.15.0-beta5, an authenticated FastGPT user can save a workflow node that points to another user's private HTTP toolset by using a crafted saved tool id such as http-<victim_toolset_app_id>/<tool_name>. The normal toolset routes deny access, but the workflow save and runtime path did not apply the same authorization check to the referenced toolset, allowing /api/v2/chat/completions to resolve the saved reference and execute the victim-owned HTTP tool. This issue is fixed in version 4.15.0-beta5.
Affected products
- labring FastGPT: from 4.14.17, < 4.15.0-beta5
References
- https://github.com/labring/FastGPT/releases/tag/v4.15.0-beta5
- https://github.com/labring/FastGPT/security/advisories/GHSA-93r3-wqq3-c5ch
- https://github.com/labring/FastGPT/security/advisories/GHSA-93r3-wqq3-c5ch
Get alerted when CVE-2026-61643 or the next vulnerability affects your stack