What’s Vulnerable › Vulnerabilities
CVE-2026-61817: pg_partman privilege escalation via SQL injection in several functions via time decoder
- Severity: high (CVSS 8.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-18 · updated 2026-09-24
- Weakness: CWE-89
Description
pg_partman is a PostgreSQL extension that manages partitioned tables by time or ID. Prior to 5.5.0, run_maintenance(), show_partitions(), show_partition_info(), undo_partition(), and partition_data_time() interpolate the writable part_config.time_dncoder text value without identifier quoting into dynamic SQL. A role with the documented partman_user privileges can store SQL rather than a decoder function name. When an affected operation later uses the poisoned value, including pg_partman_bgw maintenance for a text- or UUID-keyed set, the SQL executes with the operation's privileges, which can be the default PostgreSQL superuser background-worker role. The persistent row can restore elevated access on later ticks, and successful exploitation can permit database-wide compromise and operating-system command execution as the PostgreSQL service account. This issue is fixed in version 5.5.0.
Affected products
- pgpartman pg_partman: before 5.5.0
References
- https://github.com/pgpartman/pg_partman/commit/ba9405542acf24dd881845b935cab8b165854361
- https://github.com/pgpartman/pg_partman/releases/tag/v5.5.0
- https://github.com/pgpartman/pg_partman/security/advisories/GHSA-gmw2-52wc-258g
Get alerted when CVE-2026-61817 or the next vulnerability affects your stack