What’s Vulnerable › Vulnerabilities
CVE-2026-61858: ImageMagick before 7.1.2-26 Policy Bypass via APNG encoder
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-11 · updated 2026-10-29
- Weakness: CWE-59
Description
ImageMagick before 7.1.2-26 contains a policy bypass vulnerability in the APNG encoder and external delegates due to missing validation checks. Attackers can write files to disallowed paths by bypassing configured policy restrictions through the APNG encoding process.
Affected products
- ImageMagick: before 6.9.13-51; from 7.0.0-0 before 7.1.2-26 — fixed in 6.9.13-51, 7.1.2-26
- ImageMagick: from 7.0.0 before 7.1.2-26 — fixed in 7.1.2-26
How to fix
Upgrade to a fixed version: ImageMagick 6.9.13-51, 7.1.2-26; ImageMagick 7.1.2-26. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-v3j6-27vc-7pw2
- https://www.vulncheck.com/advisories/imagemagick-before-26-policy-bypass-via-apng-encoder
Get alerted when CVE-2026-61858 or the next vulnerability affects your stack