What’s Vulnerable › Vulnerabilities
CVE-2026-61859: ImageMagick before 7.1.2-26 Policy Bypass via script operation
- Severity: low (CVSS 3.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-15 · updated 2026-10-29
- Weakness: CWE-59
Description
ImageMagick before 7.1.2-26 and 6.9.13-x before 6.9.13-51 contains a policy bypass vulnerability in the -script operation due to missing security policy checks. This allows reading files from paths that are otherwise disallowed by the configured security policy.
Affected products
- ImageMagick: from 6.9.13-0 before 6.9.13-51; from 7.0.0-0 before 7.1.2-26 — fixed in 6.9.13-51, 7.1.2-26
- ImageMagick: from 7.0.0 before 7.1.2-26 — fixed in 7.1.2-26
How to fix
Upgrade to a fixed version: ImageMagick 6.9.13-51, 7.1.2-26; ImageMagick 7.1.2-26. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-vghg-5jrg-2398
- https://www.vulncheck.com/advisories/imagemagick-before-26-policy-bypass-via-script-operation
Get alerted when CVE-2026-61859 or the next vulnerability affects your stack