What’s Vulnerable › Vulnerabilities
CVE-2026-61866: ImageMagick before 7.1.2-26 Memory Leak in JNG encoder
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-15 · updated 2026-07-16
- Weakness: CWE-401
Description
ImageMagick before 7.1.2-26 contains a memory leak vulnerability in the JNG encoder when a blob cannot be opened. Attackers can trigger the memory leak by providing malformed JNG files that fail blob operations, causing resource exhaustion.
Affected products
- ImageMagick: before 7.1.2-26 — fixed in 7.1.2-26
How to fix
Upgrade to a fixed version: ImageMagick 7.1.2-26. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-99w9-hv66-rfv7
- https://www.vulncheck.com/advisories/imagemagick-before-26-memory-leak-in-jng-encoder
Get alerted when CVE-2026-61866 or the next vulnerability affects your stack