What’s Vulnerable › Vulnerabilities
CVE-2026-61868: ImageMagick before 7.1.2-26 Memory Leak in YUV Decoder
- Severity: low (CVSS 3.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-15 · updated 2026-10-29
- Weakness: CWE-401
Description
ImageMagick before 7.1.2-26 and 6.9.x before 6.9.13-51 contains a memory leak in the YUV decoder that occurs when opening of the blob fails. Repeated triggering can lead to resource exhaustion (denial of service).
Affected products
- ImageMagick: from 7.0.0 before 7.1.2-26 — fixed in 7.1.2-26
How to fix
Upgrade to a fixed version: ImageMagick 7.1.2-26. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-h7f2-f9cc-h2gv
- https://www.vulncheck.com/advisories/imagemagick-before-26-memory-leak-in-yuv-decoder
Get alerted when CVE-2026-61868 or the next vulnerability affects your stack