What’s Vulnerable › Vulnerabilities
CVE-2026-61897: accountsservice: incomplete privilege drop when running Ubuntu-specific language helper scripts
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-20 · updated 2026-10-18
- Weakness: CWE-273
Description
An Ubuntu-specific patch to AccountsService before 23.13.9-8ubuntu7 only partially drops privileges before launching language helper scripts. It changes the effective UID/GID to the target user but leaves the real UID as 0 (root). A shell spawned by a helper script inherits ruid=0 and may reset its effective UID to root, enabling local privilege escalation.
Affected products
- Canonical accountsservice: from 22.07.5-2ubuntu1 before 22.07.5-2ubuntu1.6; from 23.13.9-2ubuntu6 before 23.13.9-2ubuntu6.1; from 23.13.9-8ubuntu5 before 23.13.9-8ubuntu5.2; from 23.13.9-8ubuntu6 before 23.13.9-8ubuntu7 — fixed in 22.07.5-2ubuntu1.6, 23.13.9-2ubuntu6.1, 23.13.9-8ubuntu5.2, 23.13.9-8ubuntu7
How to fix
Upgrade to a fixed version: Canonical accountsservice 22.07.5-2ubuntu1.6, 23.13.9-2ubuntu6.1, 23.13.9-8ubuntu5.2, 23.13.9-8ubuntu7. Check the vendor advisory for mitigations.
References
- https://bugs.launchpad.net/ubuntu/+source/accountsservice/+bug/2157985
- https://ubuntu.com/security/CVE-2026-61897
Get alerted when CVE-2026-61897 or the next vulnerability affects your stack