What’s Vulnerable › Vulnerabilities
CVE-2026-61898: accountsservice: shell injection via attacker-controlled ~/.pam_environment in Ubuntu language helper scripts
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-20 · updated 2026-10-18
- Weakness: CWE-78
Description
The Ubuntu-specific language helper scripts (save-to-pam-env, update-langlist) shipped with accountsservice before 23.13.9-8ubuntu7 treat the user-controlled LANGUAGE entry in ~/.pam_environment as trusted input. The value is interpolated unescaped into a GNU sed replacement expression, allowing an attacker to inject a sed 'e' flag and arbitrary shell commands that execute with the privileges of the AccountsService helper process (real UID 0) via the SetLanguage D-Bus method.
Affected products
- Canonical accountsservice: from 22.07.5-2ubuntu1 before 22.07.5-2ubuntu1.6; from 23.13.9-2ubuntu6 before 23.13.9-2ubuntu6.1; from 23.13.9-8ubuntu5 before 23.13.9-8ubuntu5.2; from 23.13.9-8ubuntu6 before 23.13.9-8ubuntu7 — fixed in 22.07.5-2ubuntu1.6, 23.13.9-2ubuntu6.1, 23.13.9-8ubuntu5.2, 23.13.9-8ubuntu7
How to fix
Upgrade to a fixed version: Canonical accountsservice 22.07.5-2ubuntu1.6, 23.13.9-2ubuntu6.1, 23.13.9-8ubuntu5.2, 23.13.9-8ubuntu7. Check the vendor advisory for mitigations.
References
- https://bugs.launchpad.net/ubuntu/+source/accountsservice/+bug/2157985
- https://ubuntu.com/security/CVE-2026-61898
Get alerted when CVE-2026-61898 or the next vulnerability affects your stack