What’s Vulnerable › Vulnerabilities
CVE-2026-61899: Apache Tapestry: Possible classpath file download through URL manipulation
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-10 · updated 2026-10-24
- Weakness: CWE-200
Description
Vulnerability in tapestry-core in Apache Tapestry 5.5.0+ on all platforms allows attackers to download clsspath assets via specially crafted URLs. Users are recommended to upgrade to version 5.9.1, which fixes this issue.
Affected products
- Apache Software Foundation Apache Tapestry: from 5.5.0 before 5.9.1 — fixed in 5.9.1
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Tapestry 5.9.1. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/6j3yojqrdsxkrfz52d0zjyrf5n9xttmw
- http://www.openwall.com/lists/oss-security/2026/08/08/2
Get alerted when CVE-2026-61899 or the next vulnerability affects your stack