What’s Vulnerable › Vulnerabilities
CVE-2026-6204
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-13 · updated 2026-06-17
- Weakness: CWE-78
Description
LibreNMS versions before 26.3.0 are affected by an authenticated remote code execution vulnerability by abusing the Binary Locations config and the Netcommand feature. Successful exploitation requires administrative privileges. Exploitation could result in compromise of the underlying web server.
Affected products
- librenms: before 26.3.0 — fixed in 26.3.0
How to fix
Upgrade to a fixed version: librenms 26.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/librenms/librenms/security/advisories/GHSA-pr3g-phhr-h8fh
- https://projectblack.io/blog/librenms-authenticated-rce-and-xss/#binary-path-rce-poc
Get alerted when CVE-2026-6204 or the next vulnerability affects your stack