What’s Vulnerable › Vulnerabilities
CVE-2026-62204: SiYuan before v3.7.4 Plugin Overwrite via Bazaar Install
- Severity: medium (CVSS 6.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-22 · updated 2026-10-12
- Weakness: CWE-345
Description
SiYuan versions before v3.7.4 fail to validate that packageName matches the downloaded package content in bazaar install endpoints. Attackers with same-origin access can overwrite existing trusted plugins by supplying mismatched packageName and repoURL parameters, achieving persistence across application restarts.
Affected products
- siyuan-note siyuan: before 3.7.4 — fixed in 3.7.4
How to fix
Upgrade to a fixed version: siyuan-note siyuan 3.7.4. Check the vendor advisory for mitigations.
References
- https://github.com/siyuan-note/siyuan/security/advisories/GHSA-rpx2-p6hp-x5gj
- https://www.vulncheck.com/advisories/siyuan-before-plugin-overwrite-via-bazaar-install
Get alerted when CVE-2026-62204 or the next vulnerability affects your stack