What’s Vulnerable › Vulnerabilities
CVE-2026-62214: OpenClaw < 2026.5.28 Bot Framework SSRF via serviceUrl Parameter Validation
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-17 · updated 2026-10-24
- Weakness: CWE-522
Description
OpenClaw versions before 2026.5.28 Bot Framework contains an improper input validation vulnerability that allows lower-trust callers to expose bot tokens and credentials by failing to properly validate serviceUrl parameters. Attackers can supply malicious serviceUrl values through configured input paths to retrieve sensitive authentication data outside the trusted boundary.
Affected products
- OpenClaw: before 2026.5.28 — fixed in 2026.5.28
How to fix
Upgrade to a fixed version: OpenClaw 2026.5.28. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/security/advisories/GHSA-prwc-c6w5-mmgr
- https://www.vulncheck.com/advisories/openclaw-bot-framework-ssrf-via-serviceurl-parameter-validation
Get alerted when CVE-2026-62214 or the next vulnerability affects your stack