What’s Vulnerable › Vulnerabilities
CVE-2026-62218: OpenClaw 2026.1.20 < 2026.5.27 Authorization Bypass via device.pair.approve
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-17 · updated 2026-07-21
- Weakness: CWE-862
Description
OpenClaw 2026.1.20 before 2026.5.27 contain an authorization bypass vulnerability in the device.pair.approve feature that allows lower-trust callers to bypass role-management checks. Attackers can perform actions requiring stronger authorization by reaching the affected feature through configured input paths.
Affected products
- OpenClaw: from 2026.1.20 before 2026.5.27 — fixed in 2026.5.27
How to fix
Upgrade to a fixed version: OpenClaw 2026.5.27. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/security/advisories/GHSA-8v95-qqcm-qp9h
- https://www.vulncheck.com/advisories/openclaw-authorization-bypass-via-device-pair-approve
Get alerted when CVE-2026-62218 or the next vulnerability affects your stack