What’s Vulnerable › Vulnerabilities
CVE-2026-62222: OpenClaw < 2026.5.22 Untrusted Plugin Loading via Setup-mode
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-17 · updated 2026-07-29
- Weakness: CWE-829
Description
OpenClaw before 2026.5.22 contain a vulnerability in setup-mode discovery that allows loading of untrusted workspace plugins. Attackers with lower-trust caller access or control over configured input paths can execute or persist actions beyond their intended authorization level.
Affected products
- OpenClaw: before 2026.5.22 — fixed in 2026.5.22
How to fix
Upgrade to a fixed version: OpenClaw 2026.5.22. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/security/advisories/GHSA-rh6r-vvfc-86jq
- https://www.vulncheck.com/advisories/openclaw-untrusted-plugin-loading-via-setup-mode
Get alerted when CVE-2026-62222 or the next vulnerability affects your stack