What’s Vulnerable › Vulnerabilities
CVE-2026-62231: Grav < 1.0.6 API Key Scope Bypass via ApiKeyAuthenticator
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-17 · updated 2026-10-24
- Weakness: CWE-863
Description
The Grav API plugin (getgrav/grav-plugin-api) before 1.0.6 contains an authorization bypass: API keys can be created with a restricted scopes array, but the ApiKeyAuthenticator class never reads or enforces these scopes. It loads and returns the owning user's full account object, so a key created with limited scopes (e.g. read-only) can perform any write, delete, or administrative operation the owning user is authorized for. Fixed in 1.0.6.
Affected products
- getgrav grav: before 1.0.6 — fixed in 1.0.6
How to fix
Upgrade to a fixed version: getgrav grav 1.0.6. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/security/advisories/GHSA-x7hm-jc32-v39j
- https://www.vulncheck.com/advisories/grav-api-key-scope-bypass-via-apikeyauthenticator
- https://github.com/getgrav/grav/security/advisories/GHSA-x7hm-jc32-v39j
Get alerted when CVE-2026-62231 or the next vulnerability affects your stack