What’s Vulnerable › Vulnerabilities
CVE-2026-62233: grav-plugin-api < 1.0.6 Privilege Escalation via createApiKey
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-17 · updated 2026-10-24
- Weakness: CWE-639
Description
grav-plugin-api before 1.0.6 fails to validate super-admin status in createApiKey, generate2fa, and disable2fa endpoints, allowing non-super api.users.write managers to escalate to super-admin. Attackers can mint API keys bound to super-admin accounts or strip 2FA from super-admin users to achieve full instance takeover.
Affected products
- getgrav grav: before 1.0.6 — fixed in 1.0.6
How to fix
Upgrade to a fixed version: getgrav grav 1.0.6. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/security/advisories/GHSA-8gg4-rvvv-cq96
- https://www.vulncheck.com/advisories/grav-plugin-api-privilege-escalation-via-createapikey
Get alerted when CVE-2026-62233 or the next vulnerability affects your stack