What’s Vulnerable › Vulnerabilities
CVE-2026-62235: Grav Flex-Objects < 1.4.3 Authorization Bypass via API
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-17 · updated 2026-10-24
- Weakness: CWE-636
Description
Grav Flex-Objects before version 1.4.3 contains a broken access control vulnerability in the admin-next REST API that allows authenticated users with only api.access permission to perform unauthorized CRUD operations on permission-less directories. Attackers with api.access credentials can create, read, update, delete, and export objects from any directory lacking an explicit permissions configuration, bypassing intended authorization controls.
Affected products
- getgrav grav: before 1.4.3 — fixed in 1.4.3
How to fix
Upgrade to a fixed version: getgrav grav 1.4.3. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/security/advisories/GHSA-23vq-365v-qcmh
- https://www.vulncheck.com/advisories/grav-flex-objects-authorization-bypass-via-api
Get alerted when CVE-2026-62235 or the next vulnerability affects your stack