What’s Vulnerable › Vulnerabilities
CVE-2026-62236: grav-plugin-login < 3.8.11 CSRF via regenerate2FASecret
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-17 · updated 2026-10-24
- Weakness: CWE-352
Description
grav-plugin-login before 3.8.11 contains a cross-site request forgery (CSRF) vulnerability in the login.regenerate2FASecret frontend task, which regenerates and persists a new TOTP secret for the authenticated session user without any anti-CSRF nonce or Origin/Referer check. Because Grav core dispatches the task from the GET 'task:' URI parameter and the default session cookie is SameSite=Lax, an attacker can lure a logged-in victim to an off-site page that performs a top-level GET navigation, rotating the victim's TOTP secret so their enrolled authenticator no longer matches the server, effectively forcing 2FA re-enrollment. Sites configured with session.samesite: Strict are not affected.
Affected products
- getgrav grav: before 3.8.11 — fixed in 3.8.11
How to fix
Upgrade to a fixed version: getgrav grav 3.8.11. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/security/advisories/GHSA-4px8-7p53-282r
- https://www.vulncheck.com/advisories/grav-plugin-login-csrf-via-regenerate2fasecret
- https://github.com/getgrav/grav/security/advisories/GHSA-4px8-7p53-282r
Get alerted when CVE-2026-62236 or the next vulnerability affects your stack