What’s Vulnerable › Vulnerabilities
CVE-2026-62295: HAPI FHIR: JSON utility parser unbounded recursion causes StackOverflow denial of service
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-07 · updated 2026-09-09
- Weakness: CWE-20
Description
HAPI FHIR is a complete implementation of the HL7 FHIR standard for healthcare interoperability in Java. Prior to 6.9.11, the JSON utility parser in org.hl7.fhir.utilities.json.parser.JsonParser enforces no maximum nesting depth for arrays or objects. As a result, a small but deeply nested, syntactically valid FHIR JSON document can trigger unbounded readArray() or readObject() recursion, raising a StackOverflowError before structural validation runs. An attacker who can submit JSON resources for validation can thus crash the request thread, and services that do not isolate StackOverflowError safely may experience worker loss or process instability — a denial-of-service condition. This issue is fixed in version 6.9.11.
Affected products
- hapifhir ca.uhn.hapi.fhir:org.hl7.fhir.r5: before 6.9.11
- hapifhir ca.uhn.hapi.fhir:org.hl7.fhir.utilities: before 6.9.11
- hapifhir ca.uhn.hapi.fhir:org.hl7.fhir.validation: before 6.9.11
- hapifhir ca.uhn.hapi.fhir:org.hl7.fhir.validation.cli: before 6.9.11
- hapifhir org.hl7.fhir.core: before 6.9.11
References
- https://github.com/hapifhir/org.hl7.fhir.core/commit/396f447500407693d6ae1e64db59782862ca7506
- https://github.com/hapifhir/org.hl7.fhir.core/security/advisories/GHSA-2cq7-hg49-56gc
- https://github.com/hapifhir/org.hl7.fhir.core/security/advisories/GHSA-2cq7-hg49-56gc
Get alerted when CVE-2026-62295 or the next vulnerability affects your stack