What’s Vulnerable › Vulnerabilities
CVE-2026-62296: HAPI FHIR: XHTML narrative parser unbounded recursion causes StackOverflow denial of service
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-07 · updated 2026-09-09
- Weakness: CWE-20
Description
HAPI FHIR is a complete implementation of the HL7 FHIR standard for healthcare interoperability in Java. Prior to 6.9.11, XhtmlParser.java imposes no maximum element nesting depth, so a deeply nested text.div narrative triggers unbounded recursion between parseElementInner() and parseElement(), raising a StackOverflowError. An attacker who can submit FHIR resources containing such narratives can thus crash a parsing or validation worker thread, affecting validator services and any application that parses attacker-supplied FHIR JSON or XML. This issue is fixed in version 6.9.11.
Affected products
- hapifhir ca.uhn.hapi.fhir:org.hl7.fhir.r5: before 6.9.11
- hapifhir ca.uhn.hapi.fhir:org.hl7.fhir.utilities: before 6.9.11
- hapifhir ca.uhn.hapi.fhir:org.hl7.fhir.validation: before 6.9.11
- hapifhir ca.uhn.hapi.fhir:org.hl7.fhir.validation.cli: before 6.9.11
- hapifhir org.hl7.fhir.core: before 6.9.11
References
- https://github.com/hapifhir/org.hl7.fhir.core/commit/396f447500407693d6ae1e64db59782862ca7506
- https://github.com/hapifhir/org.hl7.fhir.core/security/advisories/GHSA-5v24-q6x8-hc38
- https://github.com/hapifhir/org.hl7.fhir.core/security/advisories/GHSA-5v24-q6x8-hc38
Get alerted when CVE-2026-62296 or the next vulnerability affects your stack