What’s Vulnerable › Vulnerabilities
CVE-2026-62312: 9Router: Authenticated RCE via Unvalidated MCP Plugin Arguments
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-15 · updated 2026-10-24
- Weakness: CWE-78
Description
9Router is an AI router & token saver. Prior to 0.5.2, 9Router allows a remote authenticated attacker to achieve arbitrary code execution on the host operating system by combining a Host header bypass of localhost-only routes with unvalidated MCP plugin args passed to child_process.spawn(), allowing malicious custom plugins to execute commands through /api/mcp//sse. This issue is fixed in version 0.5.2.
Affected products
- decolua 9router: before 0.5.2
References
- https://github.com/decolua/9router/commit/da667836cc7584bea0edd893de1d590c9ea279dc
- https://github.com/decolua/9router/releases/tag/v0.5.2
- https://github.com/decolua/9router/security/advisories/GHSA-63p9-g54h-prrp
- https://github.com/decolua/9router/security/advisories/GHSA-63p9-g54h-prrp
Get alerted when CVE-2026-62312 or the next vulnerability affects your stack