What’s Vulnerable › Vulnerabilities

CVE-2026-62354: Apache NiFi: Incorrect Authorization for Parameter Context Validation Requests

Description

Authorization handling for Parameter Context validation requests in Apache NiFi 1.10.0 through 2.10.0 allows clients with read access to submit proposed Parameter values. The proposed values override current configuration, enabling users with read access to invoke predefined component validation methods with alternative settings. Apache NiFi installations that do not implement different levels of authorization for viewing and modifying Parameter Context configuration are not subject to this vulnerability. Upgrading to Apache NiFi 2.11.0 is the recommended mitigation, requiring write access to submit Parameter Context validation requests.

Affected products

How to fix

Upgrade to a fixed version: Apache Software Foundation Apache NiFi 2.11.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-62354 or the next vulnerability affects your stack