What’s Vulnerable › Vulnerabilities
CVE-2026-62363: ImageMagick: Heap Buffer Over-Write in fx operation
- Severity: medium (CVSS 5.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-30 · updated 2026-08-03
- Weakness: CWE-787
Description
ImageMagick is free and open-source software used for editing and manipulating digital images. In versions prior to 7.1.2-27, a heap buffer over-write can occur in the fx operation by passing a crafted argument. This issue has been fixed in version 7.1.2-27.
Affected products
- ImageMagick: before 7.1.2-27 — fixed in 7.1.2-27
How to fix
Upgrade to a fixed version: ImageMagick 7.1.2-27. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-62363 or the next vulnerability affects your stack