What’s Vulnerable › Vulnerabilities

CVE-2026-62380: Netty before 4.2.16.Final SOCKS Proxy Null Byte Injection

Description

Netty (io.netty:netty-codec-socks) versions 4.2.0.Final through 4.2.16.Final and 4.1.x through 4.1.136.Final contain null byte, CRLF, and credential injection vulnerabilities in the SOCKS4 (Socks4ClientEncoder) and SOCKS5 (Socks5ClientEncoder) client encoders, which fail to validate domain address and authentication (username/password) fields. An attacker able to control these fields can inject null bytes or CRLF characters to truncate or alter values, potentially enabling domain spoofing, SOCKS4 userid truncation, authentication data injection, and protocol confusion. Fixed in 4.2.17.Final and 4.1.137.Final.

Affected products

How to fix

Upgrade to a fixed version: netty 4.1.137, 4.2.17. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-62380 or the next vulnerability affects your stack