What’s Vulnerable › Vulnerabilities
CVE-2026-62387: Grav < 1.0.0-rc.16 CORS Misconfiguration via API Plugin
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-17 · updated 2026-10-24
- Weakness: CWE-942
Description
The Grav API plugin (getgrav/grav-plugin-api) before 1.0.0-rc.16 shipped Access-Control-Allow-Origin: * as its default CORS configuration on all responses, including authenticated endpoints and preflight (OPTIONS) responses. Because the plugin accepts credentials via the Authorization and X-API-Token headers (set programmatically by JavaScript rather than via cookies), an attacker who obtains a valid access token (e.g., via log leakage, Referer headers, browser history, or network capture) can issue fully authenticated cross-origin requests from any malicious website to read sensitive data and perform write operations as the token's user. Fixed in 1.0.0-rc.16.
Affected products
- getgrav grav: before 1.0.0-rc.16 — fixed in 1.0.0-rc.16
How to fix
Upgrade to a fixed version: getgrav grav 1.0.0-rc.16. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/security/advisories/GHSA-93px-98wh-6fj2
- https://www.vulncheck.com/advisories/grav-rc-16-cors-misconfiguration-via-api-plugin
- https://github.com/getgrav/grav/security/advisories/GHSA-93px-98wh-6fj2
Get alerted when CVE-2026-62387 or the next vulnerability affects your stack