What’s Vulnerable › Vulnerabilities
CVE-2026-62388: NLTK before 3.10.0 Insecure Default Configuration in pathsec.py
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-08-22 · updated 2026-10-14
- Weakness: CWE-1188
Description
NLTK versions before 3.10.0 default to ENFORCE=False in pathsec.py, causing all security validation functions to emit warnings instead of raising exceptions. Attackers can bypass path traversal and pickle deserialization protections by exploiting the disabled security controls that are only active when manually enabled.
Affected products
- nltk: before 3.10.0 — fixed in 3.10.0
How to fix
Upgrade to a fixed version: nltk 3.10.0. Check the vendor advisory for mitigations.
References
- https://github.com/nltk/nltk/security/advisories/GHSA-p3m8-78j2-g5p3
- https://www.vulncheck.com/advisories/nltk-before-insecure-default-configuration-pathsec
- https://github.com/nltk/nltk/security/advisories/GHSA-p3m8-78j2-g5p3
Get alerted when CVE-2026-62388 or the next vulnerability affects your stack