What’s Vulnerable › Vulnerabilities
CVE-2026-62390: Apache Kylin: SQL Injection Vulnerability in Catalog Cache Refresh API
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-14 · updated 2026-10-24
- Weakness: CWE-89
Description
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Apache Kylin. A backend API refreshing table catalog may cause the injection to the generated SQL. This issue affects Apache Kylin: from 4 through 5.0.3. Users are recommended to upgrade to version 5.0.4, which fixes the issue.
Affected products
- Apache Software Foundation Apache Kylin: from 4.0.0 before 5.0.4 — fixed in 5.0.4
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Kylin 5.0.4. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/zdrj93txvdjj07f88s43d2pcg2gomvjc
- http://www.openwall.com/lists/oss-security/2026/07/14/4
Get alerted when CVE-2026-62390 or the next vulnerability affects your stack