What’s Vulnerable › Vulnerabilities
CVE-2026-62392: Apache Kylin: OS Command Injection via Async Query API
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-14 · updated 2026-10-24
- Weakness: CWE-78
Description
Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability in Apache Kylin. A backend API may bring job config parameters to OS command line. This issue affects Apache Kylin: from 4 through 5.0.3. Users are recommended to upgrade to version 5.0.4, which fixes the issue.
Affected products
- Apache Software Foundation Apache Kylin: from 4.0.0 before 5.0.4 — fixed in 5.0.4
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Kylin 5.0.4. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/9hof8lxo3mzshsh5r77mskzqlkns09gn
- http://www.openwall.com/lists/oss-security/2026/07/14/5
Get alerted when CVE-2026-62392 or the next vulnerability affects your stack