What’s Vulnerable › Vulnerabilities
CVE-2026-62393: Apache Kylin: Improper authorization in job information retrieval
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-14 · updated 2026-10-24
- Weakness: CWE-280
Description
Improper Handling of Insufficient Permissions or Privileges vulnerability in Apache Kylin. Improper authorization in job information retrieval, where an attacker may get access to unauthorized jobs in other projects. This issue affects Apache Kylin: from 4 through 5.0.3. Users are recommended to upgrade to version 5.0.4, which fixes the issue.
Affected products
- Apache Software Foundation Apache Kylin: from 4.0.0 before 5.0.4 — fixed in 5.0.4
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Kylin 5.0.4. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/xg8dcyjw0nkq5y8dhq3r25x3rxc62x9j
- http://www.openwall.com/lists/oss-security/2026/07/14/6
Get alerted when CVE-2026-62393 or the next vulnerability affects your stack