What’s Vulnerable › Vulnerabilities
CVE-2026-62440: Apache CloudStack: Improper access control in Kubernetes Service (CKS) cluster manipulation
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-21 · updated 2026-10-16
- Weakness: CWE-284
Description
Improper Access Control vulnerability in Apache CloudStack's Kubernetes Service (CKS) plugin, allowing cross-tenant manipulation of the Kubernetes cluster while adding and removing nodes. This issue affects Apache CloudStack: from 4.21.0.0 through 4.22.1.0. Users are recommended to upgrade to version 4.22.1.1 or later, which fixes the issue.
Affected products
- Apache Software Foundation Apache CloudStack: from 4.21.0.0 before 4.22.1.1 — fixed in 4.22.1.1
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache CloudStack 4.22.1.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-62440 or the next vulnerability affects your stack