What’s Vulnerable › Vulnerabilities
CVE-2026-62658: Post-authentication Command Injection Vulnerability in certain Nighthawk RAX series models
- Severity: medium (CVSS 4.7 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-14 · updated 2026-07-15
- Weakness: CWE-20
Description
A security flaw was discovered in certain NETGEAR Nighthawk RAX series routers that could allow someone already logged in to the device to run unauthorized commands or code on the router.
Affected products
- NETGEAR RAX43: before V1.0.17.142 — fixed in V1.0.17.142
- NETGEAR RAX45: before V1.0.17.142 — fixed in V1.0.17.142
- NETGEAR RAX50: before V1.0.17.142 — fixed in V1.0.17.142
- NETGEAR RAX54S: before V1.0.17.142 — fixed in V1.0.17.142
- NETGEAR RAX54Sv2: before V1.1.6.36 — fixed in V1.1.6.36
How to fix
Upgrade to a fixed version: NETGEAR RAX43 V1.0.17.142; NETGEAR RAX45 V1.0.17.142; NETGEAR RAX50 V1.0.17.142; NETGEAR RAX54S V1.0.17.142; NETGEAR RAX54Sv2 V1.1.6.36. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000070859/July-2026-NETGEAR-Security-Advisory
- https://www.netgear.com/support/product/rax43/
- https://www.netgear.com/support/product/rax45/
- https://www.netgear.com/support/product/rax50/
- https://www.netgear.com/support/product/rax54sv2/
Get alerted when CVE-2026-62658 or the next vulnerability affects your stack