What’s Vulnerable › Vulnerabilities
CVE-2026-62670: Fail-open authorization in grav-plugin-flex-objects admin-next API: api.access user gets full CRUD on permission-less directories (requireFlexPermission missing else-deny)
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-19 · updated 2026-09-09
- Weakness: CWE-862
Description
Grav Flex Objects Plugin allows you to build custom collections of objects. Prior to 1.4.3, the Grav Flex Objects Admin Next API requireFlexPermission() method in classes/Api/FlexApiController.php returns without denying access when a directory blueprint omits config.admin.permissions. An authenticated account with only api.access can use the index, show, create, update, delete, export, and media handlers for a permission-less directory even though the core admin.flex-object. authorization fallback would deny the same actions. This issue is fixed in version 1.4.3.
Affected products
- getgrav grav-plugin-flex-objects: before 1.4.3
References
- https://github.com/getgrav/grav/security/advisories/GHSA-23vq-365v-qcmh
- https://github.com/trilbymedia/grav-plugin-flex-objects/commit/198d1a0eb7b94777a026ed0001d9a369d94c3002
- https://github.com/trilbymedia/grav-plugin-flex-objects/releases/tag/1.4.3
Get alerted when CVE-2026-62670 or the next vulnerability affects your stack